How to Configure a PPPoE Connection on a Cisco Router

In this lab I will show you how to configure PPPoE connection on a Cisco router. We will be using the Cisco 1841 for this lab. First, we will erase everything on the router’s configuration and start from scratch.
STEP 1: Erasing the router

This method uses the config-register 0x2102 command in global configuration mode.

Check the configuration register on the router by issuing the show version command. The configuration register setting is displayed in the last line of the show version command output, and should be set to 0x2102. If this is not the case, enter the config-register 0x2102 command once in global configuration mode.

router# configure terminal
router(config)# config-register 0x2102
router(config)# end
router#

If the show version command is issued again, the same line in the command output will have ‘(will be 0x2102 at next reload)’ appended to the current register setting.

STEP 2: Erase the router’s configurations.

Erase the current start-up configuration on the router with the write erase command.

STEP 3: Reload the router with the reload command.

When prompted to save the configuration, DO NOT save.

router#reload


System configuration has been modified. Save? [yes/no]: n
Proceed with reload? [confirm]

Once the router reloads, the user will be presented with a ‘System Configuration Dialog’ as shown below. The router is now reset back to the original factory defaults.

— System Configuration Dialog —
Would you like to enter the initial configuration dialog? [yes/no]: n
Show the running config
Router#show run
Building configuration…
Current configuration : 658 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
no ftp-server write-enable
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
end
Router#

Paste the following configuration

no parser cache
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Test
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 192.168.1.10 192.168.1.20
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.2
!
!
no ip domain lookup
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
no ftp-server write-enable
!
interface FastEthernet0/0
description Physical ADSL Interface (Facing the ISP)
no ip address
no ip mroute-cache
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
description My LAN Interface
ip address 192.168.1.1 255.255.255.0
ip nat inside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
interface Dialer1
description Logical ADSL Interface
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxxxxxx password xxxxxxx
ppp ipcp dns request
ppp ipcp route default
ppp ipcp address accept
!
ip classless
!
!
no ip http server
no ip http secure-server
ip nat inside source list 10 interface Dialer1 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane
!
line con 0
exec-timeout 120 0
stopbits 1
line aux 0
line vty 0 4
exec-timeout 0 0
login local
length 0
!
scheduler max-task-time 5000

Step 4: Testing

Issue the command show ip int brief to show all interfaces. As you can see from the figure below, everything is up and running and the Dialer1 interface also obtained an IP address from Bell Canada.

And I tested the Internet connection; I could go to Google, anywhere….

Save the configuration:

wr mem

Restart the router and make sure it still works

 

During the reload process, there will be no Internet connectivity. Of course, when the router comes back up, I will have Internet.

As you can see that I am now able to access the Internet on a PPPoE connection using a Cisco Router.